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1. Safety and Privacy Information

In this chapter, you can find information about the intended use, the addressed target group,

and information about safety and privacy related topics. Please adhere to the ETAS Safety

Advice (accessible via Help > ETAS Safety Advice) and to the safety information given in the

user documentation.

ETAS GmbH cannot be made liable for damage which is caused by incorrect use and not

adhering to the safety messages.

1.1. Intended Use

ASCET-DEVELOPER 7.9.0 is a development tool to help you build object-based, real-time,

high-performance, low-overhead, ultra-portable, safe and secure software for embedded

hardware.

ASCET-DEVELOPER 7.9.0 lets you build programs using graphical and textual notations and

uses advanced, proven-in-use, code generation technology to automatically turn the model into

C code. The code generator handles important but tedious jobs that you normally need to worry

about when writing C code, for example, under- and overflow, division by zero, array boundary

violations, etc. You can concentrate on getting your job done while letting ASCET-DEVELOPER

handle the details. With that, ASCET-DEVELOPER makes higher quality, shorter innovation

cycles, and cost reductions a reality.

This ETAS product fulfills standard quality management requirements.

If requirements of specific safety standards (e.g. IEC 61508, ISO

26262, DO-178b, EN50128 and other similar standards) need to be

fulfilled, these requirements must be explicitly defined and ordered by

the customer. Before use of the product, customers must verify the

compliance.

1.2. Target Group

This manual addresses trained embedded software engineers. They have knowledge of the

C programming language, including the compilation, assembly, and linking of C code for

embedded applications with your chosen tool chain.

They should also be familiar with common use of the Microsoft Windows operating system.

New ASCET-DEVELOPER users should read the ASCET-DEVELOPER Getting Started guide

before installing and using ASCET-DEVELOPER 7.9.0.

1.3. Classification of Safety Messages

The safety messages used here warn of dangers that can lead to personal injury or damage to

property:

DANGER indicates a hazardous situation that, if not avoided, will result

in death or serious injury.
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WARNING indicates a hazardous situation that, if not avoided, could

result in death or serious injury.

CAUTION indicates a hazardous situation that, if not avoided, could

result in minor or moderate injury.

NOTICE indicates a situation that, if not avoided, could result in

damage to property.

1.4. Safety Information

Please adhere to the ETAS Safety Advice and to the following safety instructions to avoid injury

to yourself and others as well as damage to the device.

In addition, take all information on environmental conditions into consideration before setup and

operation (see the documentation of your computer, hardware, etc.).

Further safety advice for this ETAS product is available in the following formats:

-- In electronic form; see Documentation\ETAS Safety Advice.pdf for details.

-- The "ETAS Safety Advice" window that opens when you start the program, or when you

select Help > ETAS Safety Advice.

-- The ASCET-DEVELOPER safety manual, available at ETAS upon request.

1.5. Privacy Notice

Your privacy is important to ETAS, so we have created the following Privacy Statement that

informs you which data are processed in ASCET-DEVELOPER, which data categories ASCET-

DEVELOPER uses, and which technical measure you have to take to ensure your privacy.

Additionally, we provide further instructions where this product stores and where you can delete

personal data.

Data Processing

Note that personal data or data categories is processed when using this product. As the

controller, the purchaser undertakes to ensure the legal conformity of these processing activities

in accordance with Art. 4 No. 7 of the General Data Protection Regulation (GDPR). As the

manufacturer, ETAS GmbH is not liable for any mishandling of this data.

Data Categories

Please note that this product creates files containing file names and file paths, e.g., for purposes

of error analysis, referencing source libraries, or for communicating with third-party programs.

The same file names and file paths may contain personal data, if they refer to the current user’s

personal directory or subdirectories (e.g., C:\Users\<UserId>\ Documents\...).

If you do not want personal information to be included in the generated files, please make sure
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of the following:

-- The workspace of the product points to a directory without personal reference.

-- All settings in the product (see menu Window > Preferences in the product) refer to

directories and file names without personal reference.

-- All project settings in the product (see menu Project > Properties) refer to directories

and file names without personal reference.

-- Windows environment variables (such as the temporary directory) refer to directories

without personal reference because these environment variables are used by the product.

In this case, please also make sure that you have read and write access to all relevant

directories.

When using the ETAS License Manager in combination with user-based licenses, particularly

the following personal data or data categories are recorded for the purposes of license

management:

-- User data: UserID

-- Communication Data: IP address

Technical and Organizational Measures

This product does not itself encrypt the personal data that it records. Please ensure that the

data recorded is secured by means of suitable technical or organizational measures in your IT

system, e.g. by using classic anti-theft and access protection on the measurement hardware.

Personal data in generated files can be deleted by tools in the operating system.
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2. About ASCET-DEVELOPER

ASCET-DEVELOPER is a model-based engineering tool that helps you develop object-based,

real-time, high-performance, low-overhead, ultra-portable, safe and secure software for

embedded hardware.

2.1. Model-Based Development Approach

A model is essentially a software component which takes inputs, computes something, and

sends outputs. Your models are usually combined to form some logical composition.

2.2. ASCET-DEVELOPER Workflow

The typical workflow in ASCET-DEVELOPER has three steps:

1. Develop your models using the different editors that ASCET-DEVELOPER provides.

2. Simulate and test your models to verify that they behave as expected.

3. Generate code to deploy your models on a target device of your choice.
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Figure 1. ASCET-DEVELOPER workflow

2.3. ASCET-DEVELOPER Editors

ASCET-DEVELOPER provides several editors to develop your models. Each of these editors

comes with powerful features like content assist and model validation. Let’s have a look at the

different editors:

Block Diagram Editor

A graphical editor wherein you implement your ASCET-DEVELOPER model using blocks

and signals. Block diagram files have the .bd extension.

State Machine Editor

A graphical editor in which you mainly work with states and transitions. State machine files

have the .sm extension.

ESDL Editor

This textual editor supports you in implementing your models by directly using ASCET’s

Embedded Software Development Language (ESDL). The corresponding files have the

.esdl extension.

In ASCET-DEVELOPER, the model behavior is defined in ESDL files

only. Graphical editors are used to help you create ESDL code.
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2.4. About ESDL

ESDL is a text-based modeling language developed by ETAS. It has a similar syntactic style to

the C language family (C, C++, Java, C#). If you are familiar with any of these languages, then

you should feel comfortable with ESDL. However, unlike these languages, ESDL has been

designed to prevent many categories of coding errors and to make it easier to find other

categories of coding errors that cannot be prevented by a language alone.

ESDL embodies a best-practice approach to engineering software, using techniques and

methods that produce better results. Designing models in ESDL and then automatically

generating C code produces software that is free from the insecurities, vulnerabilities and

portability issues which are a key source of software engineering problems.

2.5. C Code Generation

In ASCET-DEVELOPER, the code generator translates your model, which consists of one or

more ESDL files, into C code. The benefit in using the ASCET-DEVELOPER code generator is

that it handles important but tedious jobs you would normally need to worry about when writing

C code, e.g. integer underflow/overflow, division by zero or array boundary violations. With that,

you can concentrate on getting your job done while letting ASCET-DEVELOPER handle the

details.

The generated code is target-independent. This gives you the flexibility to integrate your models

on basically any embedded device.

Application Software

ASCET-DEVELOPER models can be used to generate the application software code of your

embedded project.

Device Drivers

Device drivers directly interface with and control specific hardware functions within the

microcontroller unit (MCU), such as bus or I/O initialization and transaction drivers, memory

and memory management drivers, and control drivers.

Operating Environment

This could, for example, be a real time operating system (OS) - a full-featured one like Linux

or bare metal with an infinite loop.
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3. Installation

This chapter provides relevant information to all users who install, maintain or uninstall ASCET-

DEVELOPER on a PC or a network.

3.1. Preparing the Installation

ASCET-DEVELOPER is provided as a downloadable electronic installation image. You will have

been provided with access to the download when the product was purchased.

3.1.1. Delivery Scope

The delivery scope of ASCET-DEVELOPER contains the following content:

-- ASCET-DEVELOPER 7.9.0 program files

-- ETAS Experiment Environment

-- ETAS Virtual Prototyping Platform

-- ASCET-DEVELOPER Getting Started manual in PDF format (reader required)

-- information on open-source components used in ASCET-DEVELOPER

3.1.2. System Requirements

The software prerequisites and system requirements are listed in the release notes of ASCET-

DEVELOPER.

3.2. All-in-One Installation

This section describes the common installation of ASCET-DEVELOPER, the ETAS Experiment

Environment, and the ETAS Virtual Prototyping Platform (VP Platform in short). The ETAS

Experiment Environment and the ETAS Virtual Prototyping Platform are necessary if you want to

use the ASCET-DEVELOPER PC experiment.

The all-in-one installation does not allow user-defined parameters.

User-defined parameters, e.g., installation path, are only possible when

you install each tool separately. See also section 3.3, “Separate

Installations”.

3.2.1. Installation via Dialog Windows

This section describes the installation via dialog windows. Command-line installation is

described in section 3.3.1.2, “Command-Line Installation”.
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To start the ASCET-DEVELOPER installation

1. In the file system, open the ASCET-DEVELOPER 7.9.0.iso file.[1]

2. Double-click the Setup ASCET-DEVELOPER 7.9.0.exe file.

The ASCET-DEVELOPER Setup Wizard is launched.

Figure 2. ASCET-DEVELOPER Setup Wizard

3. Click Next.
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To check for blocking applications

The "Running applications" window shows running applications that block the installation.

1. Do the following:

i. Close each application with its native closing mechanism.

ii. In the "Running applications" window, right-click each application and select Close

from the context menu.

Once all blocking applications are closed, the installation continues automatically.

To select components to be installed

The "Choose Components" window lists all components that can be installed.
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Figure 3. ASCET-DEVELOPER Setup — Choose Components

1. Activate the checkbox of each component you want to install.

By default, all checkboxes are activated.

To install ASCET-DEVELOPER

The next step starts the installation. You cannot abort it.

1. In the "Choose Components" window, click Install.

The installation is performed. A progress indicator shows how the installation is

progressing. When the installation is complete, the "Installation Complete" window opens.

2. Click Next.

You are prompted to finish the installation.
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Figure 4. Completing the all-in-one installation

3. Click Finish to complete the installation.

ASCET-DEVELOPER

For ASCET-DEVELOPER, a folder named ETAS ASCET-DEVELOPER 7.9 is created in the

ETAS program group of the Windows Start menu. It contains the following entries:

-- ASCET-DEVELOPER 7.9

Starts ASCET-DEVELOPER.

-- ASCET-DEVELOPER 7.9.0 Getting Started

Link to the Getting Started manual for ASCET-DEVELOPER.

-- ASCET-DEVELOPER 7.9.0 Release Notes

Link to the Release Notes for ASCET-DEVELOPER.

The following icon is placed on the desktop of your computer:

The ETAS License Manager has an entry ETAS License Manager in the ETAS program group

of the Start menu.

Experiment Environment

For the experiment environment, a folder ETAS Experiment Environment <a>.<b>[2] is

created in the Windows Start menu. This folder contains the following items:
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-- Experiment Environment V<a>.<b>[2]

Opens the experiment environment.

-- Experiment Environment V<a>.<b>[2] Tools

Opens a folder with the following shortcuts in the Windows Explorer:

● Associate to INCA

Determines the INCA version that can be used with the experiment environment,

and the version of the shared modules.

● Associate to RTA-TRACE

Checks the installation of RTA-TRACE. If the check fails, hints for troubleshooting

are given.

-- INCA <x>.<y> Target Server — Tools

Opens a folder with the following shortcuts in the Windows Explorer:

● ETAS Network settings

Starts the assistant for the configuration of the ETAS network.

● Search for connected hardware

The Target server is started. A search for connected hardware is conducted.

-- Manuals and Tutorials

Opens the ETAS Manuals folder in the Windows Explorer. The ETAS Manuals folder

contains a shortcut Experiment Environment V<a>.<b>`[2], which opens the
`Docs folder with the following online help files:

● EE.chm

The Experiment Environment online help.

● InstrumentProgramming.chm

A help file that offers assistance for programming and integrating user-defined

instruments to the ETAS experiment environment.

● ScriptingAPI_EE.chm

A help file that describes the scripting API of the experiment environment.

● XILAPI_EE.chm

A help file that describes the XIL API of the experiment environment.

The following icon is stored on the desktop of your computer:

The SMF editor has its own entries in the Start menu; they can be found at E > ETAS > *, with *

being one of the following:

-- SMFEditor User Guide
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Opens the online help for the SMF editor.

-- SuT Mapping File Editor

Opens the SMF editor.

VP Platform

For the VP Platform, a folder ETAS ETAS Virtual OS Execution Platform <c>.<d>[

3] is created in the Windows Start menu. This folder contains a single entry, Signal

Configuration Editor V<m>.<n>[4], which is irrelevant for ASCET-DEVELOPER.

3.2.2. What is Installed?

After installing completes, a number of new files and folders are created in the ASCET-

DEVELOPER installation directory C:\ETAS\ASCET-DEVELOPER7.9. The following table

describes the most important elements:

File/Folder Description

ASCET.exe The ASCET-DEVELOPER IDE executable

ASCET.ini Startup configuration options for ASCET-DEVELOPER

amd-to-esdl-cli.bat ASCET 6 AMD to ESDL translation tool

ascet-cli.bat The ASCET-DEVELOPER command line code

generator driver

configuration Folder with configuration files

documents Folder with user documentation in PDF form

features Standard Eclipse Folder: Contains definitions of which

plugins contribute to which feature

jre Standard Eclipse Folder: Java SE Runtime Environment

LicenseConfigurationInfo Folder with license features to which the ETAS License

Manager needs to grant access.

p2 Standard Eclipse Folder: Plugin dependency

management

plugins Standard Eclipse Folder: IDE plugins

SDK Folder with ZIP files for ASCET-DEVELOPER SDK and

ASCET-DEVELOPER Javadoc.

Table 1. ASCET-DEVELOPER — most important files and folders

The ASCET-DEVELOPER 7.9.0 installation includes the Eclipse C/C++ Development tools (see

www.eclipse.org/cdt/) so that you can work easily with generated C code.
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3.3. Separate Installations

This section describes the separate installations of ASCET-DEVELOPER, the ETAS Experiment

Environment, and the ETAS Virtual Prototyping Platform (VP Platform in short). The ETAS

Experiment Environment and the ETAS Virtual Prototyping Platform are necessary if you want to

use the ETAS PC experiment.

When you install ASCET-DEVELOPER, the ETAS Experiment

Environment, and the VP Platform separately, you can set some

installation parameters for each tool.

3.3.1. Installing Only ASCET-DEVELOPER

The ASCET-DEVELOPER installer installs the following items:

-- ASCET-DEVELOPER product

-- ETAS License Manager

-- all 3rd-party tools required to run ASCET-DEVELOPER or the ETAS License Manager

3.3.1.1. Installation via Dialog Windows

This section describes the installation via dialog windows. Command-line installation is

described in section 3.3.1.2, “Command-Line Installation”.

To start the ASCET-DEVELOPER installation

1. In the file system, open the ASCET-DEVELOPER 7.9.0.iso file.[1]

2. In the install folder of the ASCET-DEVELOPER 7.9.0.iso file, double-click

setup.exe.

The ASCET-DEVELOPER Setup Wizard (see Figure 2) is launched.

3. Click Next to get to the next installation window.
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To check for blocking applications

The "Verifying conditions" window shows running applications that block the installation.

1. Close each applications with its closing mechanism.

Once all blocking applications are closed, the installation continues automatically.

Or

2. Do the following:

i. Click Next without closing the blocking applications.

You are asked if you want to close the applications.

ii. Click Yes to continue.

If an application cannot be closed normally, you are asked if you want to kill the

respective process.

Killing a process can lead to data loss.

Make sure that no data will be lost before you agree to kill

the process.

iii. Click Yes to continue.

To define path settings

In the "Choose Install Location" window, you are prompted to enter a destination directory for

the installation (later referred to as <installation>.
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Figure 5. ASCET-DEVELOPER Setup — Choose Install Location

1. Enter or select (via the Browse button) a valid path.

Make sure that you select an installation directory that offers

write access during ASCET-DEVELOPER operation; ASCET-

DEVELOPER writes to files in the installation directory.

It is recommended that you do not use the Program Files
directory as installation directory.

The default installation directory for ASCET-DEVELOPER 7.9.0 is C:\ETAS\ASCET-
DEVELOPER7.9.

An invalid path deactivates the Next button. You have to correct the path before you can

continue.

2. Click Next.

If ASCET-DEVELOPER 7.9.* is already installed in the selected directory, or if you
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selected an existing directory, you are asked to uninstall the existing installation.

3. Click Yes to continue.

Use No to return to the "Choose Install Location" window and specify another installation

directory.

If the existing folder does not contain an installation of ASCET-DEVELOPER 7.9.*, the

folder is deleted. Continue reading at "To specify a folder in the Start menu".

To uninstall an existing version

If you selected an existing folder that contains an installation of ASCET-DEVELOPER, the

"Uninstall ETAS ASCET-DEVELOPER" window opens.

1. Click Next.

The existing version is uninstalled. Once uninstallation is complete, the Close button is

available.

2. Click Close.
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The installation continues.

To specify a folder in the Start menu

In the "Choose Start Menu Folder" window, you are prompted to enter or select a Start menu

folder for ASCET-DEVELOPER.

Figure 6. ASCET-DEVELOPER Setup — Choose Start Menu Folder

1. Do one of the following:

● Accept the default folder name.

● Enter a new folder name.

If desired, you can enter folder and subfolder.

To install ASCET-DEVELOPER

The next step starts the installation. You cannot abort it.

1. In the "Choose Start Menu Folder" window, click Install.

The installation is performed. A progress indicator shows how the installation is

progressing. When the installation is complete, the "Installation Complete" window opens.

2. Click Next.

You are prompted to finish the installation.
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Figure 7. Completing the ASCET-DEVELOPER installation

3. If desired, activate the Open ASCET-DEVELOPER 7.9.0 Getting Started option.

4. Click Finish to complete the installation.

In the Windows Start menu, the specified folder is created. By default, that folder is named

ETAS ASCET-DEVELOPER 7.9; see also "To specify a folder in the Start menu". See section

ASCET-DEVELOPER for a list of the folder’s content.

The following icon is placed on the desktop of your computer:

Table 1 lists the most important files and folders of the ASCET-DEVELOPER installation.

3.3.1.2. Command-Line Installation

This section describes the command-line installation. Installation via dialog windows is

described in section 3.3.1.1.

When you start the ASCET-DEVELOPER installation from a command line, you can use several

command-line parameters to customize the installation.

The command-line options are case-sensitive. For example, /S will

cause a silent installation, but /s will not.
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/? or /h

Opens a window with the valid command line arguments.

/S or /silent

Silent installation mode. With this installation mode, no dialog windows requiring user

information open.

Default values are used for all information normally requested in installation windows. Error

messages are hidden, too.

/silent must be the first command-line argument. If other

arguments precede it, /silent has no effect.

/NCRC

Skips CRC check of the installer (ignored if CRCCheck force is set in the installer).

/D

Sets the installation directory ($INSTDIR).

/D must be the last parameter in the command line. /D must not contain any quotes.

Syntax

without spaces  —  /D=C:\ETAS\ASCET-DEVELOPER<x>.<y>[5]

with spaces  —  /D=C:\Program Files\ASCET-DEVELOPER

Examples

setup.exe /S /EULAAccepted

Triggers a silent installation with default installation path and CRC check.

setup.exe /NCRC /D=C:\Tools\ASCET-DEVELOPER<x>.<y> [5]

Triggers a non-silent installation without CRC check and with user-defined installation

directory.

3.3.2. Installing the Experiment Environment

You need the ETAS Experiment Environment and the ETAS Virtual Prototyping Platform if you

want to use the ASCET-DEVELOPER PC experiment.

You cannot choose the installation path of the experiment environment. The experiment

environment is installed in the Program Files (x86) folder, Common
Files\ETAS\Experiment Environment\<a>.<b>[2] subfolder, on your system drive.

3.3.2.1. Installation via Dialog Windows

To start the experiment environment installation

1. In the file system, open the ASCET-DEVELOPER 7.9.0.iso file.[1]

2. In the install\ExperimentEnvironment folder of the *.iso file, double-click

setup.exe.

Installation | 23

ASCET-DEVELOPER 7.9.0 | Getting Started



The ETAS Installer is launched.

Figure 8. ETAS Installer for the experiment environment

3. Click Next to continue.

The installer checks if your computer meets the system requirements for installation of

the experiment environment. The result is displayed in the "System Check" window.

If your system meets the installation requirements, the installer proceeds automatically to

the next window.

To uninstall an existing version

If no incompatible version of the Experiment Environment is installed

on your computer, continue with To accept the license agreement.

If an Experiment Environment version incompatible with the version you are about to install is

present on your computer, that version is listed in the "Uninstall previous products" window.
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1. Click Uninstall now.

The previous version of the Experiment Environment is uninstalled. You can now continue

the installation of the new version of the Experiment Environment.

To accept the license agreement

The next window shows the license agreement.
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Figure 9. Experiment environment installation — license agreement

1. Read the license agreement, then activate the I read and accept the terms in the

License Agreement option.

If you do not accept the license agreement, you cannot continue the installation.

2. Click Next.

To associate with INCA

The "Associate to INCA" window offers all INCA versions on your PC that can access the same

target server as the experiment environment.
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Figure 10. Experiment environment installation — associate with INCA

1. Select the INCA version you want to associate with the ETAS experiment environment.

2. Click Next to continue.

To install the experiment environment

The "Ready to install" window lists the components selected for installation.
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The next step will start the installation. You cannot cancel installation

once it is running; the Cancel button is deactivated.

1. In the "Ready to Install" window, click Install.

The ETAS Experiment Environment is installed. A progress indicator shows how the

installation is progressing.

To complete the installation

Once all components have been installed successfully, you are prompted to end the installation.

1. Click Finish to end the installation.

2. If you are asked to restart the computer, do so before you start the Experiment

Environment.

The entry E > ETAS Experiment Environment <a>.<b>[2] is created in the Windows Start

menu. See section Experiment Environment for a list of the entry’s content.

The following icon is stored on the desktop of your computer:

3.3.2.2. Setting the Licensing Behavior

You can define the way in which the experiment environment (and other ETAS software

programs) accesses the required licenses in the [Licensing] section of an *.ini file.

The install\ExperimentEnvironment\Packages\ExperimentEnvironment folder in

your ASCET-DEVELOPER 7.9.0.iso file contains such an *.ini file, i.e. Licensing.ini.

You can copy this file to a local directory and adapt it according to your needs.

To define the access to the required licenses

1. Open the Licensing.ini file with a text editor.

2. Modify the settings in the [Licensing] section as desired.

The parameters and their settings are described below.

3. Save your changes.

The following parameters can be used:

-- LicenseFileName

Defines the absolute path and file name of the license file which is to be added.

-- LicensesToBorrow

You can use this setting if licenses can be borrowed from a license server. To enable the

borrow mechanism, you must enter the name of the product or features license (e.g., EE).

If you enter more than one license, the license names must be separated by blanks.

The experiment environment uses the following licenses:
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License name Functionality

EE experiment environment

INT_VP_EE Virtual Prototyping Package for the experiment

environment

COSYM_CCI,

COSYM_SIL_EE,

INT_RP_EE,

INT_UCC_LCO_FIL,

LCS_LCO_CCI,

LCS_LCO_LCE,

LCS_LCO_LCX

irrevelant for the combination of the ETAS Experiment

Environment and ASCET-DEVELOPER

-- BorrowExpiryMode

Defines the way in which the expiration of the borrow status is given. Possible values are:

● Date

If the BorrowExpiryMode is set to Date, the borrow period will expire at a certain

date which is specified under BorrowExpiryDate.

● Interval

If the BorrowExpiryMode is set to Interval, the borrow period will expire after

a certain number of days which is specified under BorrowExpiryInterval.

-- BorrowExpiryDate

If the BorrowExpiryMode is set to Date, this parameter specifies the date when the

borrow period expires. The format is yyyy-mm-dd.

-- BorrowExpiryInterval

If the BorrowExpiryMode is set to Interval, this parameter specifies the length of the

borrow period in days.

-- BorrowAutomaticExtensionInterval

This parameter specifies the borrow interval in days that is applied when an automatic

extension of the borrow period is executed (as defined under

ExecuteBorrowAutomaticExtensionInterval).

-- ExecuteBorrowAutomaticExtensionInterval

Defines at what point of time the borrow period will be automatically extended. This

parameter specifies the number of days before the expiration of the current borrow

period. When this time is reached, the borrow period is automatically extended to the

interval specified under BorrowAutomaticExtensionInterval.

-- ImmediateBorrow

You can define that a license is automatically borrowed. Possible values are:

● true

The license is borrowed automatically at installation time.
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ImmediateBorrow='true' works only for the user who

performs the installation. Other users who work on the

same computer do not own the borrowed license.

● false

The license will be borrowed at the first time when the program connects to the

license server.

-- CustomLicenseFolder

Due to the fact that the default location for added license files (e.g.,

C:\ProgramData\ETAS\FlexNet for Windows 10) is only writable for users with

admin rights, a different path for the license file folder may be specified with this

parameter.

The following example defines that borrowing is enabled for the experiment environment. The

license will be borrowed when the experiment environment is started for the first time; by default

the licenses expire after 100 days.

[Licensing]
LicenseFileName = 'd:\licenses\MyLicense.lic'
LicensesToBorrow = 'EE'
LicensesToBorrow = 'INT_VP_EE'
BorrowExpiryMode = 'Interval'
BorrowExpiryInterval = '100'
ImmediateBorrow = 'false'

3.3.2.3. Command-Line Installation

If you start the installation of the experiment environment from a command line, you can use

several command-line parameters to customize the installation.

The following command-line options exist:

/silent

Silent installation mode. With this installation mode, no dialog windows requiring user

information open.

To accept EULA (cf. Figure 9) during silent installation, you must

use the command-line parameter /EULAAccepted.

To deal with a possible request for a computer restart, you must use

either the /NoRestart or the /AllowRestart command-line

parameter.

To automatically uninstall an existing older version of the

experiment environment, you must use the

/UninstallPreviousVersion command-line parameter.

Default values are used for all information normally requested in installation windows. Error

messages are hidden, too.

/EULAAccepted

Accepts the license agreement.
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The text of the license agreement is provided on the installation disk, in the

experimentEnvironment\EULA subfolders.

/NoRestart

Suppresses a computer restart that may be required at the end of the installation. If a reboot

is suppressed, a log message is issued.

/AllowRestart

Allows a computer reboot restart that may be required at the end of the installation. A restart

is performed without further notice.

/UninstallPreviousVersion

Uninstalls an existing older version of the experiment environment installed on your

computer.

If you do not use this command-line parameter, setup.exe will

abort with an error if a previous version of the experiment

environment is found.

/UninstallPreviousVersion is not used in combination with /Uninstall.

/Debug

Writes additional log files for *.msi packages.

These files are stored in the %appdata%\ETAS\SETUP folder.[6]

/DefaultSettings

Allows to specify an own XML file with default settings (instead of using

InstallationDefaultSettings.xml).

You can specify a relative path if the file is relative to setup.exe, otherwise you have to

specify an absolute path.

Syntax: /DefaultSettings:"<path>\<filename>.xml"

/uninstall

Uninstalls the experiment environment. Can be combined with /silent for uninstallation

without user interaction.

Use the setup.exe file provided in the C:\Program Files (x86)\ETAS\
GENericSetup\EE EE Standalone\<a>.<b>.<c>.<d> folder.

Examples

Setup.exe /silent /EULAAccepted

Triggers a silent installation.

"C:\Program Files (x86)\ETAS\GENericSetup\EE EE Standalone\
<a>.<b>.<c>.<d>\setup.exe" /uninstall /Debug

Triggers a non-silent uninstallation and writes additional logs.

setup.exe /DefaultSettings:"D:\myOwnSettings.xml"

Triggers a non-silent installation that uses your own default settings for the installation.
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3.3.3. Installing the ETAS Virtual Prototyping Platform

You need the ETAS Experiment Environment and the ETAS Virtual Prototyping Platform (VP

platform) if you want to use the ASCET PC experiment.

To start the VP Platform installation

1. In the file system, open the ASCET-DEVELOPER 7.9.0.iso file.[1]

2. In the install\VirtualOSExecutionPlatform folder of the *.iso file, double-click

setup.exe.

The ETAS Installer is launched.

Figure 11. ETAS Installer for the Virtual Prototyping Platform

3. Follow the instructions in the installer window.

4. After installation, you are asked if you want to reboot. You must reboot before an

experiment can be run.
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3.4. Licensing

A valid license is required for using ASCET-DEVELOPER. You can obtain a license in one of

the following ways:

-- from your tool coordinator

-- via the self-service portal on the ETAS website at www.etas.com/support/licensing

-- via the ETAS License Manager

To activate the license, you must enter the Activation ID that you received from ETAS during the

ordering process.

For more information about ETAS license management, see the ETAS License Management

FAQ or the ETAS License Manager help.

To open the ETAS License Manager help

The ETAS License Manager is available on your computer after the installation of any ETAS

software.

1. From the Windows Start menu, select E > ETAS > ETAS License Manager.

The ETAS License Manager opens.

2. Click in the ETAS License Manager window and press F1 .

The ETAS License Manager help opens.

3.5. Post-Installation Setup

It is recommended that you install the MinGW PC-hosted C compiler so that you can compile

the code natively for the PC using the Eclipse CDT (e.g. so that you can test programs running

on the host PC).

ASCET-DEVELOPER includes an installation of GCC in the <installation>\
plugins\org.mingw.gcc.x86_Win32_<i>.<j>.<k>.<l>\mingw folder.[7]

To use this version with the Eclipse CDT version, add <installation>\plugins\
org.mingw.gcc.x86_Win32_<i>.<j>.<k>.<l>\mingw\bin to the Windows path.

3.6. Changing the Installation Location after Installation

The ASCET-DEVELOPER installation is self-contained. To change the installation location after

installing, simply copy the entire ASCET-DEVELOPER folder to the required location

3.7. Uninstalling ASCET-DEVELOPER

Use one of the following ways to start the uninstall process for the ASCET-DEVELOPER:

-- Programs and Features from the Windows control panel

-- Apps > Apps & features from the Windows Settings
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To uninstall ASCET-DEVELOPER via dialog windows

1. Start the uninstall procedure.

The uninstaller is launched.

2. Click Next to uninstall ASCET-DEVELOPER.

The uninstaller checks if your computer allows uninstallation of ASCET-DEVELOPER.

If not, the "Verifying conditions" window opens. It lists the applications that disallow

uninstallation.
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The next step will start the uninstallation. You cannot cancel the

uninstallation once it is running.

3. Close each blocking application with its closing mechanism, then click Uninstall.

OR

4. Do the following:

i. Click Uninstall without closing the blocking applications.

You are asked if you want to close the applications.

ii. Click Yes to continue.

If an application cannot be closed normally, you are asked if you want to kill the

respective process.

Killing a process can lead to data loss.

Make sure that no data will be lost before you agree to kill

the process.

iii. Click Yes to continue.

ASCET-DEVELOPER is uninstalled.

A progress indicator shows how the uninstallation is progressing. Once all components

have been uninstalled, a success window opens.

5. Click Close to end the uninstallation.

You can also use the uninstall.exe file in the ASCET-DEVELOPER installation directory to
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uninstall ASCET-DEVELOPER via command line. The command-line parameter /S (see Silent

Installation) is also available for silent uninstallation.

[1] You can mount the *.iso file with a double-click, or you can unpack the file with an archive tool

like 7-zip.

[2] <a>.<b> is the 2-digit version number of the ETAS Experiment Environment.

[3] <c>.<d> is the version number of the VP Platform.

[4] <m>.<n> is the version number of the signal configuration editor.

[5] <x>.<y> is the ASCET-DEVELOPER version number

[6] By default, %appdata% = C:\Users\<username>\AppData\Roaming.

[7] <i>, <j>, <k>, and <l> are parts of the compiler’s version number
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4. Developing Software with ASCET-DEVELOPER

ASCET-DEVELOPER is an Eclipse-based product. If you are familiar with using the Eclipse

environment then you should feel at home. If ASCET-DEVELOPER is the first Eclipse-based

application you have used, then section 4.1 provides some basic information to get you started.

4.1. Starting ASCET-DEVELOPER for the First Time

To start ASCET-DEVELOPER, run the program from the Start Menu, the desktop icon, or by

navigating to the installation directory and double-clicking ASCET.exe.

When you start ASCET-DEVELOPER for the first time, you are asked for a workspace location.

A workspace is the root Windows folder where all your programs and the generated code will be

saved.

Figure 12. "Workspace Launcher" window

You can do the following:

-- Enter or select (via the Browse button) an existing folder.

-- Enter or select a new folder.

-- Activate Use this as the default … to make the folder the default workspace and avoid

further inquiries.

You can undo the activation in the "Preferences" window, "General\Startup and

Shutdown\Workspaces" node.

You can change the workspace later from within ASCET-DEVELOPER.

-- Continue (Launch) or cancel the procedure.

Next, the "ETAS Safety Advice" window opens. It contains safety information in several

languages.
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Figure 13. ETAS Safety Advice

Read the Safety Advice carefully before you click Acknowledged.

You can open the Safety Advice in the ASCET-DEVELOPER window

via Help > Safety Advice. A PDF version, ETAS Safety
Advice.pdf, is available in the ASCET-DEVELOPER installation

directory, documents subfolder.

The first time you run ASCET-DEVELOPER, you are shown the "Welcome" page. This page

provides links to useful information.
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Figure 14. ASCET-DEVELOPER window, showing the Welcome page

To reach the workbench, close the Welcome page.
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Figure 15. ASCET-DEVELOPER window, showing an empty workspace

You can return to the "Welcome" page at any time using the menu item Help > Welcome.

4.2. Installing the Examples

The best place to start is with the example applications. ASCET-DEVELOPER ships with a

number of examples that are extensively commented to show you the important features of the

language.

To install an example

1. Select File > New > Example.

The "New Example" window opens.
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Figure 16. "New Example" window

2. Select an example (e.g., Block Diagrams) from the list.

3. Click Next.

The second page of the "New Example" window opens. It lists the example projects that

will be created.

4. Click Finish.

The example you selected will be installed in the workspace, and you are ready to go.

Each example project is installed into its own Eclipse project (the root folder) and the source
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code in a subfolder. All ASCET-DEVELOPER block diagram files use the extension .bd, all

ESDL source files use the extension .esdl.

The ASCET-DEVELOPER editor provides context-sensitive editing features that you expect to

find in Eclipse. If you do not know what to type, try pressing Ctrl  +  Space  to get suggestions. If

you have typed something that is wrong, but cannot work out how to fix it, try pressing Ctrl  +  1 ;

you may find a quick fix to help you.

4.3. Tutorials

Basic and an advanced product tutorials are provides in the ASCET-DEVELOPER online help.

To access them, proceed as follows:

1. After starting ASCET-DEVELOPER and opening a workspace, select the Help > Help

Contents menu option.

2. Go to the ASCET-DEVELOPER User Guide and open the "Getting Started" chapter.

3. If you do not want to read the entire "Getting Started" chapter, go directly to section

"Basic Tutorials" or "Advanced Tutorials".
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5. Finding Out More

ASCET-DEVELOPER ships with extensive online help. To view the help, select Help > Help

Contents from the menu.

-- ASCET-DEVELOPER User Guide

This describes how to develop software in ASCET-DEVELOPER.

-- ESDL User Guide

This describes how to develop software ESDL and provides the ESDL Language

Reference.

-- ASCET-DEVELOPER Javadoc

This describes the ASCET-DEVELOPER API.

In addition, ASCET-DEVELOPER includes the standard documentation for the Eclipse platform

& plugins shipped as part of the ASCET-DEVELOPERonline help:

-- Workbench User Guide

This explains how to use the standard Eclipse workbench.

-- C/C++ Development User Guide

This explains how to use the Eclipse C/C++ development tooling.

-- Eclipse Marketplace User Guide

This describes how to use the Eclipse Marketplace to search and install plugins.

There is extensive documentation on the internet about using Eclipse, and a good starting point

is www.eclipse.org/.
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6. Contact Information

Technical Support

For details of your local sales office as well as your local technical support team and product

hotlines, take a look at the ETAS website:

www.etas.com/hotlines

ETAS Headquarters

ETAS GmbH

Borsigstraße 24 Phone: +49 711 3423-0

70469 Stuttgart Fax: +49 711 3423-2106

Germany Internet: www.etas.com
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Glossary

This section lists terms and abbreviations relevant for ASCET-DEVELOPER.

API

Application programming interface

ESDL

Embedded Software Development Language; a high-level programming language for writing

real-time, deeply embedded software.

GCC

GNU compiler collection

Host PC

The PC where you are running ASCET-DEVELOPER.

IDE

integrated development environment

MISRA

Motor Industry Software Reliability Association

SDK

software development kit

Target hardware

The hardware for which you compile the C code you generated with ASCET-DEVELOPER.

VP

Virtual prototyping

VP Platform

ETAS Virtual Prototyping Platform
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